我一定写了一个假的技术博客
当前位置: 首页>> 技术宅 >> 正文

SpringBoot整合Dubbo并集成Zookeeper的依赖说明

2020年03月02日 1 条评论 ... 技术宅 / /

Dubbo 的版本和版本之间的变化差距比较大。

截止到2020年3月2日,Dubbo 官方公布的最新版本的 dubbo-spring-boot-starter 是 0.2.1.RELEASE, 相对于之前的版本 0.2.0,去掉了 zookeeper 、dubbo 相关 jar 包的依赖,这样做可以灵活的处理依赖。

0.2.0 的内部依赖如图:

1583122773(1)

0.2.1.RELEASE 的依赖如图:

1583122867(1)

 

如果你还是想要搭建一个经典 Dubbo 的 SpringBoot 程序,使用 zookeeper 来作为注册中心,那么只需要仿照 0.2.0 版本的依赖手动依赖一次即可。(官方给的 zookeeper 依赖样例没有直接给出 zoookeeper 依赖的版本号,造成了一定的困扰)

 

实际的依赖可能就非常简洁明了(只是 dubbo 和 zookeeper 相关)

  1. <!--dubbo --> 
  2. <dependency> 
  3.     <groupId>com.alibaba.boot</groupId> 
  4.     <artifactId>dubbo-spring-boot-starter</artifactId> 
  5.     <version>0.2.1.RELEASE</version> 
  6. </dependency> 
  7. <dependency> 
  8.     <groupId>com.alibaba</groupId> 
  9.     <artifactId>dubbo</artifactId> 
  10.     <version>2.6.5</version> 
  11. </dependency> 
  12.  
  13. <!-- Zookeeper --> 
  14. <dependency> 
  15.     <groupId>org.apache.zookeeper</groupId> 
  16.     <artifactId>zookeeper</artifactId> 
  17.     <version>3.4.9</version> 
  18. </dependency> 
  19. <dependency> 
  20.     <groupId>org.apache.curator</groupId> 
  21.     <artifactId>curator-framework</artifactId> 
  22.     <version>2.12.0</version> 
  23. </dependency> 

 

如果大家想要尝试学习 dubbo 首要推荐的是 dubbo 的 github,里面有对应的中文版本说明,其次的话,建议搜索引擎设置只查询最近一个月,这样可以避免找到很老的 dubbo 教程,节约时间。

版权保护: 本文由 唐野 原创,转载请保留链接: http://www.yelook.com/2349.html

1 条吐槽

Loading...
  1. 姜辰

    看到大佬这些,我突然想请教一下大佬关于正则表达式的,如何用正则在sql 清除所有的html代码呢?主要是

    26天前 [回复]

发布评论